Notice: Undefined index: HTTP_ACCEPT_LANGUAGE in /www/wwwroot/hnzhev.com/wp-content/themes/riplus/helper/swoole-compiler-loader.php on line 158
Swoole Compiler Loader Wizard-vip.ylit.cc

Swoole Compiler 安装向导

(RiPlus内测版本支撑PHP7.4!swoole扩展也需要更新)


检查当前环境
  • 操作系统 : Linux VM-0-14-centos 3.10.0-1127.19.1.el7.x86_64 #1 SMP Tue Aug 25 17:23:54 UTC 2020 x86_64
  • PHP版本 : 7.0.33
  • PHP运行环境 : fpm-fcgi
  • PHP配置文件 : /www/server/php/70/etc/php.ini
  • PHP扩展安装目录 : /www/server/php/70/lib/php/extensions/no-debug-non-zts-20151012
  • PHP是否线程安全 : 非线程安全
  • 是否安装swoole_loader : 未安装

安装和配置Swoole Loader

1 - 点击下载 unix PHP7.0 Swoole Loader扩展文件

RiPlus主题当前内测版本,swoole扩展需要更新,不建议和旧版本有安装swoole的php站点版本同一个环境使用

2 - 安装Swoole Loader

将刚才下载的Swoole Loader扩展文件(swoole_loader70.so)上传到当前PHP的扩展安装目录中:

/www/server/php/70/lib/php/extensions/no-debug-non-zts-20151012

3 - 修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

编辑此PHP配置文件:/www/server/php/70/etc/php.ini,在此文件底部结尾处加入如下配置

extension=swoole_loader70.so
注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

4 - 重启服务器

重启PHP或者重启服务器

XML 地图 | Sitemap 地图